Main Page

Daunytools DLL Documentation

  • Main Page
  • File List
  • Globals
Generated on Sun May 18 13:43:58 2003 for Daunytools DLL by doxygen 1.3-rc3


File Index

Daunytools DLL File List

Here is a list of all files with brief descriptions:
daunytools.h [code]
Generated on Sun May 18 13:43:58 2003 for Daunytools DLL by doxygen 1.3-rc3


daunytools.h File Reference

#include <windows.h>
#include <Shlwapi.h>

Go to the source code of this file.

Defines

#define | MAJOR_VERSION "1"
#define | MINOR_VERSION "4"
#define | BUILD_NUMBER "0"
#define | DLL_VERSION MAJOR_VERSION "." MINOR_VERSION
#define | DAUNYTOOLS_API __declspec(dllimport)
#define | DAUNYTOOLSDLL_NOERROR 0
#define | CAN_NOT_CONNECT_TO_SERVICE_CONTROL_MANAGER 10
#define | CAN_NOT_OPEN_SERVICE 11
#define | CAN_NOT_START_SERVICE 12
#define | CAN_NOT_STOP_SERVICE 13
#define | CAN_NOT_GET_STATUS_OF_THE_SERVICE 14
#define | SERVICE_NOT_STARTED 15
#define | SERVICE_NOT_STOPPED 16
#define | SERVICE_WORKS_ONLY_WITH_WINDOWS_NT 17
#define | CAN_NOT_OPEN_DAUNY_PID_FILE 20
#define | CAN_NOT_READ_DAUNY_PID 21
#define | CAN_NOT_ACCESS_PROCESS 22
#define | PROCESS_NOT_TERMINATED 23
#define | PROCESS_NOT_STARTED 24
#define | COMMAND_NOT_SENT 30
#define | TRAYICON_MOUSEFIRST 1
#define | TRAYICON_LBUTTONDBLCLK 2
#define | TRAYICON_LBUTTONDOWN 3
#define | TRAYICON_LBUTTONUP 4
#define | TRAYICON_RBUTTONDOWN 5
#define | TRAYICON_RBUTTONUP 6
#define | TRAYICON_RBUTTONDBLCLK 7
#define | TRAYICON_MBUTTONDOWN 8
#define | TRAYICON_MBUTTONUP 9
#define | TRAYICON_MBUTTONDBLCLK 10
#define | DAUNY_SERVICE_UNKNOWN 0
#define | DAUNY_SERVICE_CONTINUE_PENDING 1
#define | DAUNY_SERVICE_PAUSE_PENDING 2
#define | DAUNY_SERVICE_PAUSED 3
#define | DAUNY_SERVICE_RUNNING 4
#define | DAUNY_SERVICE_START_PENDING 5
#define | DAUNY_SERVICE_STOP_PENDING 6
#define | DAUNY_SERVICE_STOPPED 7
#define | IE6_INTEGRATION_MODE_ASK_FOR_DOWNLAOD 1
#define | IE6_INTEGRATION_MODE_ALWAYS_DOWNLOAD 2
#define | IE6_INTEGRATION_MODE_NEVER_DOWNLAOD 3
#define | IE6_INTEGRATION_MODE_DOWNLAOD_AND_REPORT_FAIL 4
#define | MAX_USER_NAME_LENGTH 100
#define | MAX_USER_PASS_LENGTH 100

Functions

DAUNYTOOLS_API int | IsWindowsNT (void)
Check für OS Windows NT (Windows NT 4.0, Windows 2K, Windows XP) [since v1.3].

DAUNYTOOLS_API int | ShutdownSystem ()
Start system shutdown [since v1.3].

DAUNYTOOLS_API int | StartDauny (const char *FileName)
Start dauny program (with console) [since v1.3].

DAUNYTOOLS_API int | StopDauny (const char *szPath)
Stops dauny program (console) [since v1.3].

DAUNYTOOLS_API int | KillDauny (const char *szPath)
Terminates dauny program (console) immediately (ony for emergency or hang) [since v1.4].

DAUNYTOOLS_API int | StartDaunyService (void)
Start installed dauny service (daemon) [since v1.3].

DAUNYTOOLS_API int | StopDaunyService (void)
Stop installed dauny service (daemon) [since v1.3].

DAUNYTOOLS_API int | GetDaunyServiceState ()
Gets the state of dauny service (daemon) [since v1.4].

DAUNYTOOLS_API int | DaunyOnline (const char *szPath)
Send Dauny to online mode (console and service) [since v1.4].

DAUNYTOOLS_API int | DaunyOffline (const char *szPath)
Send Dauny to offline mode (console and service) [since v1.4].

DAUNYTOOLS_API char * | EncryptPasswort (const char *szUncryptPassword, const char *Key)
Function to encrypt dauny password [since v1.3].

DAUNYTOOLS_API int | LoadTrayIcon (char *szIconFileName, int nIndex, char *szToolTip)
Function to load single trayicon [since v1.3].

DAUNYTOOLS_API int | LoadTrayIcons (char *DllORIconName, int nFileIndex, int nIndex, int nIconCount)
Function to load multiple trayicons out of a dll or exe file [since v1.3].

DAUNYTOOLS_API int | SetTrayIconToolTip (int nIndex, char *szToolTip)
Set trayicon tooltip (possible for loaded, unloaded, shown and hidden icons) [since v1.3].

DAUNYTOOLS_API int | ShowTrayIcon (int nIndex)
Shows loaded trayicon [since v1.3].

DAUNYTOOLS_API int | RemoveTrayIcon ()
Removes actual shown trayicon (Trayicon thread still active after call) [since v1.3].

DAUNYTOOLS_API int | DestoryTrayIconThread ()
Destroys trayicon thread (needed for java applications, c bases programms don't need to call this its done by FreeLibrary()) [since v1.3].

DAUNYTOOLS_API int | GoOnline ()
Establish internet connection if it is allowed [since v1.3].

DAUNYTOOLS_API int | GoOffline ()
Close internet connection if it is allowed [since v1.3].

DAUNYTOOLS_API int | IsOnline ()
Check online Status [since v1.3].

DAUNYTOOLS_API int | RegisterIE6IntegrationDLL ()
Register Internet Explorer integration dll [since v1.4].

DAUNYTOOLS_API int | UnregisterIE6IntegrationDLL ()
Unregister Internet Explorer integration dll [since v1.4].

DAUNYTOOLS_API int | IE6IntegrationEnable ()
Enables Internet Explorer Integration [since v1.4].

DAUNYTOOLS_API int | IE6IntegrationDisable ()
Disables Internet Explorer Integration [since v1.4].

DAUNYTOOLS_API int | IE6IntegrationSetMode (int nMode)
Set the Internet Explorer Integration mode [since v1.4].

DAUNYTOOLS_API int | IE6IntegrationGetMode ()
Get the Internet Explorer Integration mode (see IE6_INTEGRATION_MODE_...

DAUNYTOOLS_API int | IE6IntegrationSetQuestionText (char *szQuestion)
Set the Internet Explorer Question text (displayed if user clicks on a link) [since v1.4].

DAUNYTOOLS_API char * | IE6IntegrationGetQuestionText ()
Get the Internet Explorer Question text (displayed if user clicks on a link) [since v1.4].

DAUNYTOOLS_API char * | DllVersion ()
Get Dll version number [since v1.3].

DAUNYTOOLS_API char * | DllDaunyVersion ()
Get dauny version belong to dll [since v1.4].

DAUNYTOOLS_API HRESULT CALLBACK | DllGetVersion (DLLVERSIONINFO *pdvi)
Windows standard function to get version of dll [since v1.4].

Variables

DAUNYTOOLS_API float | daunytoolsdll_Version
Holds Dll version number [since v1.3].

Define Documentation

#define BUILD_NUMBER "0"

#define CAN_NOT_ACCESS_PROCESS 22

#define CAN_NOT_CONNECT_TO_SERVICE_CONTROL_MANAGER 10

#define CAN_NOT_GET_STATUS_OF_THE_SERVICE 14

#define CAN_NOT_OPEN_DAUNY_PID_FILE 20

#define CAN_NOT_OPEN_SERVICE 11

#define CAN_NOT_READ_DAUNY_PID 21

#define CAN_NOT_START_SERVICE 12

#define CAN_NOT_STOP_SERVICE 13

#define COMMAND_NOT_SENT 30

#define DAUNY_SERVICE_CONTINUE_PENDING 1

Dauny service continue is pending

#define DAUNY_SERVICE_PAUSE_PENDING 2

Dauny service pause is pending

#define DAUNY_SERVICE_PAUSED 3

Dauny service is paused

#define DAUNY_SERVICE_RUNNING 4

Dauny service is running

#define DAUNY_SERVICE_START_PENDING 5

Dauny service is starting

#define DAUNY_SERVICE_STOP_PENDING 6

Dauny service is stopping

#define DAUNY_SERVICE_STOPPED 7

Dauny service is not running

#define DAUNY_SERVICE_UNKNOWN 0

Dauny service state is unknown

#define DAUNYTOOLS_API __declspec(dllimport)

Dll export function

#define DAUNYTOOLSDLL_NOERROR 0

#define DLL_VERSION MAJOR_VERSION "." MINOR_VERSION

Dll version string

#define IE6_INTEGRATION_MODE_ALWAYS_DOWNLOAD 2

Internet Explorer always uses dauny download

#define IE6_INTEGRATION_MODE_ASK_FOR_DOWNLAOD 1

Internet Explorer ask for dauny download (Yes,No,Abort)

#define IE6_INTEGRATION_MODE_DOWNLAOD_AND_REPORT_FAIL 4

Internet Explorer uses dauny download, but reports an error, so IE also starts the download

#define IE6_INTEGRATION_MODE_NEVER_DOWNLAOD 3

Internet Explorer never uses dauny download

#define MAJOR_VERSION "1"

#define MAX_USER_NAME_LENGTH 100

maximum string length of user name

#define MAX_USER_PASS_LENGTH 100

maximum string length of user password

#define MINOR_VERSION "4"

#define PROCESS_NOT_STARTED 24

#define PROCESS_NOT_TERMINATED 23

#define SERVICE_NOT_STARTED 15

#define SERVICE_NOT_STOPPED 16

#define SERVICE_WORKS_ONLY_WITH_WINDOWS_NT 17

#define TRAYICON_LBUTTONDBLCLK 2

Trayicon mouse left double click

#define TRAYICON_LBUTTONDOWN 3

Trayicon mouse left button down (MouseCallback())

#define TRAYICON_LBUTTONUP 4

Trayicon mouse left button up (MouseCallback())

#define TRAYICON_MBUTTONDBLCLK 10

Trayicon mouse middle double click (MouseCallback())

#define TRAYICON_MBUTTONDOWN 8

Trayicon mouse middle button down (MouseCallback())

#define TRAYICON_MBUTTONUP 9

Trayicon mouse middle button up (MouseCallback())

#define TRAYICON_MOUSEFIRST 1

Mouse first time over icon (transmited many times) (MouseCallback())

#define TRAYICON_RBUTTONDBLCLK 7

Trayicon mouse right double click (MouseCallback())

#define TRAYICON_RBUTTONDOWN 5

Trayicon mouse right button down (MouseCallback())

#define TRAYICON_RBUTTONUP 6

Trayicon mouse right button up (MouseCallback())

Function Documentation

DAUNYTOOLS_API int DaunyOffline ( const char * szPath )

Send Dauny to offline mode (console and service) [since v1.4].

Parameters:
FileName Path to dauny program (see StartDauny())
Returns:
Error number or zero for no errors.
  • CAN_NOT_OPEN_DAUNY_PID_FILE
  • CAN_NOT_READ_DAUNY_PID
  • COMMAND_NOT_SENT

DAUNYTOOLS_API int DaunyOnline ( const char * szPath )

Send Dauny to online mode (console and service) [since v1.4].

Parameters:
FileName Path to dauny program (see StartDauny())
Returns:
Error number or zero for no errors.
  • CAN_NOT_OPEN_DAUNY_PID_FILE
  • CAN_NOT_READ_DAUNY_PID
  • COMMAND_NOT_SENT

DAUNYTOOLS_API int DestoryTrayIconThread ( )

Destroys trayicon thread (needed for java applications, c bases programms don't need to call this its done by FreeLibrary()) [since v1.3].

Returns:
one for OK, zero for error

DAUNYTOOLS_API char* DllDaunyVersion ( )

Get dauny version belong to dll [since v1.4].

Returns:
dauny version number string

DAUNYTOOLS_API HRESULT CALLBACK DllGetVersion ( DLLVERSIONINFO * pdvi )

Windows standard function to get version of dll [since v1.4].

Parameters:
pdvi Version number as DLLVERSIONINFO struct (output)
Returns:
errorcode as HRESULT

DAUNYTOOLS_API char* DllVersion ( )

Get Dll version number [since v1.3].

Returns:
Dll version number string

DAUNYTOOLS_API char* EncryptPasswort | ( | const char * | szUncryptPassword,
 |  | const char * | Key
 | ) |

Function to encrypt dauny password [since v1.3].

Parameters:
szUncryptPassword | Native password string
Key | Received connection key by dauny server
Returns:
encrypted password

DAUNYTOOLS_API int GetDaunyServiceState ( )

Gets the state of dauny service (daemon) [since v1.4].

Returns:
actual state of dauny service
  • DAUNY_SERVICE_UNKNOWN
  • DAUNY_SERVICE_CONTINUE_PENDING
  • DAUNY_SERVICE_PAUSE_PENDING
  • DAUNY_SERVICE_PAUSED
  • DAUNY_SERVICE_RUNNING
  • DAUNY_SERVICE_START_PENDING
  • DAUNY_SERVICE_STOP_PENDING
  • DAUNY_SERVICE_STOPPED

DAUNYTOOLS_API int GoOffline ( )

Close internet connection if it is allowed [since v1.3].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int GoOnline ( )

Establish internet connection if it is allowed [since v1.3].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int IE6IntegrationDisable ( )

Disables Internet Explorer Integration [since v1.4].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int IE6IntegrationEnable ( )

Enables Internet Explorer Integration [since v1.4].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int IE6IntegrationGetMode ( )

Get the Internet Explorer Integration mode (see IE6_INTEGRATION_MODE_...

defines) [since v1.4]

Returns:
Internet Explorer Integration mode number

DAUNYTOOLS_API char* IE6IntegrationGetQuestionText ( )

Get the Internet Explorer Question text (displayed if user clicks on a link) [since v1.4].

Returns:
Question text

DAUNYTOOLS_API int IE6IntegrationSetMode ( int nMode )

Set the Internet Explorer Integration mode [since v1.4].

Parameters:
nMode Internet Explorer Integration mode number (see IE6_INTEGRATION_MODE_... defines)
Returns:
one for OK, zero for error

DAUNYTOOLS_API int IE6IntegrationSetQuestionText ( char * szQuestion )

Set the Internet Explorer Question text (displayed if user clicks on a link) [since v1.4].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int IsOnline ( )

Check online Status [since v1.3].

Returns:
one for Online, zero for offline

DAUNYTOOLS_API int IsWindowsNT ( void )

Check für OS Windows NT (Windows NT 4.0, Windows 2K, Windows XP) [since v1.3].

Returns:
one for WindowsNT, zero for other OS

DAUNYTOOLS_API int KillDauny ( const char * szPath )

Terminates dauny program (console) immediately (ony for emergency or hang) [since v1.4].

Parameters:
FileName Path to dauny program (see StartDauny())
Returns:
Error number or zero for no errors.
  • CAN_NOT_OPEN_DAUNY_PID_FILE
  • CAN_NOT_READ_DAUNY_PID
  • CAN_NOT_ACCESS_PROCESS
  • PROCESS_NOT_TERMINATED

DAUNYTOOLS_API int LoadTrayIcon | ( | char * | szIconFileName,
 |  | int | nIndex,
 |  | char * | szToolTip
 | ) |

Function to load single trayicon [since v1.3].

Parameters:
szIconFileName | Path with filename to icon (.ico)
nIndex | Index for icon (see ShowTrayIcon())
szToolTip | Tooltip text for trayicon
Returns:
Count of successful loaded icons

DAUNYTOOLS_API int LoadTrayIcons | ( | char * | DllORIconName,
 |  | int | nFileIndex,
 |  | int | nIndex,
 |  | int | nIconCount
 | ) |

Function to load multiple trayicons out of a dll or exe file [since v1.3].

Parameters:
DllORIconName | Path with filename to icon (.ico), Library (.dll) or executeable File (.exe)
nFileIndex | Start index of Icon in the file, to load
nIndex | Index for icon (see ShowTrayIcon())
nIconCount | Count of icons to load
Returns:
Count of successful loaded icons

DAUNYTOOLS_API int RegisterIE6IntegrationDLL ( )

Register Internet Explorer integration dll [since v1.4].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int RemoveTrayIcon ( )

Removes actual shown trayicon (Trayicon thread still active after call) [since v1.3].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int SetTrayIconToolTip | ( | int | nIndex,
 |  | char * | szToolTip
 | ) |

Set trayicon tooltip (possible for loaded, unloaded, shown and hidden icons) [since v1.3].

Parameters:
nIndex | Index for icon (see ShowTrayIcon())
szToolTip | Tooltip text for trayicon
Returns:
one for OK, zero for error

DAUNYTOOLS_API int ShowTrayIcon ( int nIndex )

Shows loaded trayicon [since v1.3].

Parameters:
nIndex Index of loaded icon
Returns:
one for OK, zero for error

DAUNYTOOLS_API int ShutdownSystem ( )

Start system shutdown [since v1.3].

Returns:
one for OK, zero for error

DAUNYTOOLS_API int StartDauny ( const char * FileName )

Start dauny program (with console) [since v1.3].

Parameters:
FileName Path with filename to dauny program.
Returns:
Error number or zero for no errors
  • PROCESS_NOT_STARTED

DAUNYTOOLS_API int StartDaunyService ( void )

Start installed dauny service (daemon) [since v1.3].

Returns:
Error number or zero for no errors
  • SERVICE_WORKS_ONLY_WITH_WINDOWS_NT
  • CAN_NOT_CONNECT_TO_SERVICE_CONTROL_MANAGER
  • CAN_NOT_OPEN_SERVICE
  • CAN_NOT_START_SERVICE
  • CAN_NOT_GET_STATUS_OF_THE_SERVICE
  • SERVICE_NOT_STARTED

DAUNYTOOLS_API int StopDauny ( const char * szPath )

Stops dauny program (console) [since v1.3].

Parameters:
FileName Path to dauny program (see StartDauny())
Returns:
Error number or zero for no errors.
  • CAN_NOT_OPEN_DAUNY_PID_FILE
  • CAN_NOT_READ_DAUNY_PID
  • PROCESS_NOT_TERMINATED

DAUNYTOOLS_API int StopDaunyService ( void )

Stop installed dauny service (daemon) [since v1.3].

Returns:
Error number or zero for no errors
  • SERVICE_WORKS_ONLY_WITH_WINDOWS_NT
  • CAN_NOT_CONNECT_TO_SERVICE_CONTROL_MANAGER
  • CAN_NOT_OPEN_SERVICE
  • CAN_NOT_STOP_SERVICE
  • CAN_NOT_GET_STATUS_OF_THE_SERVICE
  • SERVICE_NOT_STOPPED

DAUNYTOOLS_API int UnregisterIE6IntegrationDLL ( )

Unregister Internet Explorer integration dll [since v1.4].

Returns:
one for OK, zero for error

Variable Documentation

DAUNYTOOLS_API float daunytoolsdll_Version

Holds Dll version number [since v1.3].

Generated on Sun May 18 13:43:58 2003 for Daunytools DLL by doxygen 1.3-rc3


File Member Index

Daunytools DLL Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:
  • BUILD_NUMBER : daunytools.h
  • CAN_NOT_ACCESS_PROCESS : daunytools.h
  • CAN_NOT_CONNECT_TO_SERVICE_CONTROL_MANAGER : daunytools.h
  • CAN_NOT_GET_STATUS_OF_THE_SERVICE : daunytools.h
  • CAN_NOT_OPEN_DAUNY_PID_FILE : daunytools.h
  • CAN_NOT_OPEN_SERVICE : daunytools.h
  • CAN_NOT_READ_DAUNY_PID : daunytools.h
  • CAN_NOT_START_SERVICE : daunytools.h
  • CAN_NOT_STOP_SERVICE : daunytools.h
  • COMMAND_NOT_SENT : daunytools.h
  • DAUNY_SERVICE_CONTINUE_PENDING : daunytools.h
  • DAUNY_SERVICE_PAUSE_PENDING : daunytools.h
  • DAUNY_SERVICE_PAUSED : daunytools.h
  • DAUNY_SERVICE_RUNNING : daunytools.h
  • DAUNY_SERVICE_START_PENDING : daunytools.h
  • DAUNY_SERVICE_STOP_PENDING : daunytools.h
  • DAUNY_SERVICE_STOPPED : daunytools.h
  • DAUNY_SERVICE_UNKNOWN : daunytools.h
  • DaunyOffline() : daunytools.h
  • DaunyOnline() : daunytools.h
  • DAUNYTOOLS_API : daunytools.h
  • DAUNYTOOLSDLL_NOERROR : daunytools.h
  • daunytoolsdll_Version : daunytools.h
  • DestoryTrayIconThread() : daunytools.h
  • DLL_VERSION : daunytools.h
  • DllDaunyVersion() : daunytools.h
  • DllGetVersion() : daunytools.h
  • DllVersion() : daunytools.h
  • EncryptPasswort() : daunytools.h
  • GetDaunyServiceState() : daunytools.h
  • GoOffline() : daunytools.h
  • GoOnline() : daunytools.h
  • IE6_INTEGRATION_MODE_ALWAYS_DOWNLOAD : daunytools.h
  • IE6_INTEGRATION_MODE_ASK_FOR_DOWNLAOD : daunytools.h
  • IE6_INTEGRATION_MODE_DOWNLAOD_AND_REPORT_FAIL : daunytools.h
  • IE6_INTEGRATION_MODE_NEVER_DOWNLAOD : daunytools.h
  • IE6IntegrationDisable() : daunytools.h
  • IE6IntegrationEnable() : daunytools.h
  • IE6IntegrationGetMode() : daunytools.h
  • IE6IntegrationGetQuestionText() : daunytools.h
  • IE6IntegrationSetMode() : daunytools.h
  • IE6IntegrationSetQuestionText() : daunytools.h
  • IsOnline() : daunytools.h
  • IsWindowsNT() : daunytools.h
  • KillDauny() : daunytools.h
  • LoadTrayIcon() : daunytools.h
  • LoadTrayIcons() : daunytools.h
  • MAJOR_VERSION : daunytools.h
  • MAX_USER_NAME_LENGTH : daunytools.h
  • MAX_USER_PASS_LENGTH : daunytools.h
  • MINOR_VERSION : daunytools.h
  • PROCESS_NOT_STARTED : daunytools.h
  • PROCESS_NOT_TERMINATED : daunytools.h
  • RegisterIE6IntegrationDLL() : daunytools.h
  • RemoveTrayIcon() : daunytools.h
  • SERVICE_NOT_STARTED : daunytools.h
  • SERVICE_NOT_STOPPED : daunytools.h
  • SERVICE_WORKS_ONLY_WITH_WINDOWS_NT : daunytools.h
  • SetTrayIconToolTip() : daunytools.h
  • ShowTrayIcon() : daunytools.h
  • ShutdownSystem() : daunytools.h
  • StartDauny() : daunytools.h
  • StartDaunyService() : daunytools.h
  • StopDauny() : daunytools.h
  • StopDaunyService() : daunytools.h
  • TRAYICON_LBUTTONDBLCLK : daunytools.h
  • TRAYICON_LBUTTONDOWN : daunytools.h
  • TRAYICON_LBUTTONUP : daunytools.h
  • TRAYICON_MBUTTONDBLCLK : daunytools.h
  • TRAYICON_MBUTTONDOWN : daunytools.h
  • TRAYICON_MBUTTONUP : daunytools.h
  • TRAYICON_MOUSEFIRST : daunytools.h
  • TRAYICON_RBUTTONDBLCLK : daunytools.h
  • TRAYICON_RBUTTONDOWN : daunytools.h
  • TRAYICON_RBUTTONUP : daunytools.h
  • UnregisterIE6IntegrationDLL() : daunytools.h
Generated on Sun May 18 13:43:58 2003 for Daunytools DLL by doxygen 1.3-rc3


daunytools.h Source File

daunytools.h

Go to the documentation of this file.
00001 // Der folgende ifdef-Block zeigt die Standardlösung zur Erstellung von Makros, die das Exportieren
00002 // aus einer DLL vereinfachen. Alle Dateien in dieser DLL wurden mit dem in der Befehlszeile definierten
00003 // Symbol DAUNYTOOLS_EXPORTS kompiliert. Dieses Symbol sollte für kein Projekt definiert werden, das
00004 // diese DLL verwendet. Auf diese Weise betrachtet jedes andere Projekt, dessen Quellcodedateien diese Datei
00005 // einbeziehen, DAUNYTOOLS_API-Funktionen als aus einer DLL importiert, während diese DLL mit diesem
00006 // Makro definierte Symbole als exportiert betrachtet.
00007
00008 #ifndef _Included_DaunyToolsDll
00009 #define _Included_DaunyToolsDll
00010
00011 #include <windows.h>
00012 #include <Shlwapi.h>
00013
00014 #ifdef __cplusplus
00015 extern "C" {
00016 #endif // __cplusplus
00017
00018 #define MAJOR_VERSION  "1"
00019 #define MINOR_VERSION  "4"
00020 #define BUILD_NUMBER   "0"
00021
00025 #define DLL_VERSION MAJOR_VERSION "." MINOR_VERSION
00026
00030 #ifdef DAUNYTOOLS_EXPORTS
00031         #define DAUNYTOOLS_API __declspec(dllexport)
00032 #else
00033         #define DAUNYTOOLS_API __declspec(dllimport)
00034 #endif
00035
00036 #define DAUNYTOOLSDLL_NOERROR                       0
00037 #define CAN_NOT_CONNECT_TO_SERVICE_CONTROL_MANAGER  10
00038 #define CAN_NOT_OPEN_SERVICE                        11
00039 #define CAN_NOT_START_SERVICE                       12
00040 #define CAN_NOT_STOP_SERVICE                        13
00041 #define CAN_NOT_GET_STATUS_OF_THE_SERVICE           14
00042 #define SERVICE_NOT_STARTED                         15
00043 #define SERVICE_NOT_STOPPED                         16
00044 #define SERVICE_WORKS_ONLY_WITH_WINDOWS_NT          17
00045
00046 #define CAN_NOT_OPEN_DAUNY_PID_FILE                 20
00047 #define CAN_NOT_READ_DAUNY_PID                      21
00048 #define CAN_NOT_ACCESS_PROCESS                      22
00049 #define PROCESS_NOT_TERMINATED                      23
00050 #define PROCESS_NOT_STARTED                         24
00051
00052 #define COMMAND_NOT_SENT                            30
00053
00054
00058 #define TRAYICON_MOUSEFIRST     1
00059
00062 #define TRAYICON_LBUTTONDBLCLK  2
00063
00066 #define TRAYICON_LBUTTONDOWN    3
00067
00070 #define TRAYICON_LBUTTONUP      4
00071
00074 #define TRAYICON_RBUTTONDOWN    5
00075
00078 #define TRAYICON_RBUTTONUP      6
00079
00082 #define TRAYICON_RBUTTONDBLCLK  7
00083
00086 #define TRAYICON_MBUTTONDOWN    8
00087
00090 #define TRAYICON_MBUTTONUP      9
00091
00094 #define TRAYICON_MBUTTONDBLCLK  10
00095
00096
00100 #define DAUNY_SERVICE_UNKNOWN           0
00101
00104 #define DAUNY_SERVICE_CONTINUE_PENDING  1
00105
00108 #define DAUNY_SERVICE_PAUSE_PENDING     2
00109
00112 #define DAUNY_SERVICE_PAUSED            3
00113
00116 #define DAUNY_SERVICE_RUNNING           4
00117
00120 #define DAUNY_SERVICE_START_PENDING     5
00121
00124 #define DAUNY_SERVICE_STOP_PENDING      6
00125
00128 #define DAUNY_SERVICE_STOPPED           7
00129
00130 // Internet Explorer integration Modes  (see SetIntegrationMode())
00134 #define IE6_INTEGRATION_MODE_ASK_FOR_DOWNLAOD          1
00135
00138 #define IE6_INTEGRATION_MODE_ALWAYS_DOWNLOAD           2
00139
00142 #define IE6_INTEGRATION_MODE_NEVER_DOWNLAOD            3
00143
00146 #define IE6_INTEGRATION_MODE_DOWNLAOD_AND_REPORT_FAIL  4
00147
00151 #define MAX_USER_NAME_LENGTH    100
00152
00155 #define MAX_USER_PASS_LENGTH    100
00156
00157 //system - Export functions
00162 DAUNYTOOLS_API int  IsWindowsNT(void);
00167 DAUNYTOOLS_API int  ShutdownSystem();
00168 //dauny control - Export functions
00175 DAUNYTOOLS_API int   StartDauny(const char* FileName);
00184 DAUNYTOOLS_API int   StopDauny(const char* szPath);
00194 DAUNYTOOLS_API int   KillDauny(const char* szPath);
00205 DAUNYTOOLS_API int   StartDaunyService(void);
00216 DAUNYTOOLS_API int   StopDaunyService(void);
00229 DAUNYTOOLS_API int   GetDaunyServiceState();
00238 DAUNYTOOLS_API int   DaunyOnline(const char* szPath);
00247 DAUNYTOOLS_API int   DaunyOffline(const char* szPath);
00254 DAUNYTOOLS_API char* EncryptPasswort(const char* szUncryptPassword,const char* Key);
00255 //Tray Icon - Export functions
00263 DAUNYTOOLS_API int   LoadTrayIcon(char* szIconFileName,int nIndex,char* szToolTip);
00272 DAUNYTOOLS_API int   LoadTrayIcons(char* DllORIconName,int nFileIndex,int nIndex,int nIconCount);
00279 DAUNYTOOLS_API int   SetTrayIconToolTip(int nIndex,char* szToolTip);
00285 DAUNYTOOLS_API int   ShowTrayIcon(int nIndex);
00290 DAUNYTOOLS_API int   RemoveTrayIcon();
00295 DAUNYTOOLS_API int   DestoryTrayIconThread();
00296 //Internet dial up - Export functions
00301 DAUNYTOOLS_API int   GoOnline ();
00306 DAUNYTOOLS_API int   GoOffline ();
00311 DAUNYTOOLS_API int   IsOnline ();
00316 DAUNYTOOLS_API int   RegisterIE6IntegrationDLL();
00321 DAUNYTOOLS_API int   UnregisterIE6IntegrationDLL();
00326 DAUNYTOOLS_API int   IE6IntegrationEnable();
00331 DAUNYTOOLS_API int   IE6IntegrationDisable();
00337 DAUNYTOOLS_API int   IE6IntegrationSetMode(int nMode);
00342 DAUNYTOOLS_API int   IE6IntegrationGetMode();
00347 DAUNYTOOLS_API int   IE6IntegrationSetQuestionText(char* szQuestion);
00352 DAUNYTOOLS_API char* IE6IntegrationGetQuestionText();
00353
00358 //DLL Info - Export functions
00359 DAUNYTOOLS_API char* DllVersion();
00364 DAUNYTOOLS_API char* DllDaunyVersion();
00370 DAUNYTOOLS_API HRESULT CALLBACK DllGetVersion(DLLVERSIONINFO* pdvi);
00374 extern DAUNYTOOLS_API float daunytoolsdll_Version;
00375
00376
00377 // MOUSE CALLBACK FUNCTION - Could be implemented in your exe- or java-program
00378 /*
00379 /*
00380  * Mouse event related to trayicon (extra thread) [since v1.3]
00381  * @param nType Mouse event Type
00382  *         - TRAYICON_LBUTTONDBLCLK
00383  *         - TRAYICON_LBUTTONDOWN
00384  *         - TRAYICON_LBUTTONUP
00385  *         - TRAYICON_RBUTTONUP
00386  *         - TRAYICON_RBUTTONUP
00387  *         - TRAYICON_MOUSEFIRST
00388  * @return reserved (not used)
00389
00390 extern "C" __declspec(dllexport) int MouseCallback(int nType){}   for  C
00391
00392 public class DaunyNativeFunctions {
00393         public void MouseCallback(int nType) {}                         for  java
00394 }
00395 */
00396
00397 //GetFileVersionInfo
00398 #ifdef __cplusplus
00399 }
00400 #endif // __cplusplus
00401
00402
00403 #endif // _Included_DaunyToolsDll
Generated on Sun May 18 13:43:58 2003 for Daunytools DLL by doxygen 1.3-rc3